
Mission Statement

In a global society with ever-changing technological advances, students need knowledge 

and experience to succeed in the 21st  century.  Using an innovative approach to learning, the role 

of computer education is to equip students with information, media and technology skills.   

As technology educators, our role is to facilitate this process by providing a classroom 

structure that includes critical thinking, creative problem solving, effective communication, and 

collaboration involving inquiry-based activities.  After completion of the computer program, 

students will be well prepared for success both personally and professionally.

Curriculum Modifications for Special Needs Children

The Linden Board of Education recognizes that children possess varied learning abilities, rates, and capacities. Users of this document should understand that the following program modifications are acceptable to make the computer curriculum compatible with the broad continuum of students learning styles and abilities.  

For students eligible for educational accommodations consistent with section 504 of the Americans with Disabilities Act, the goals and activities contained in the child’s IEP or 504 Plan should be used to determine responsibility for the attainment of subject matter content.  

	Unit Overview 

	Content Area: Technology/Computers

	Unit Title: Keyboarding 

	Target Course/Grade Levels: K-5

	Unit Summary: 
Keyboarding: Through the use of a typing program student will become familiar with the home Keys,  the home row, top row & bottom row
Interdisciplinary Connections:  
Language Arts, Foreign Languages

21st Century Themes:  
People in the 21st century live in a technology and media-suffused environment, marked by various characteristics, including: 1) access to an abundance of information, 2) rapid changes in technology tools, and 3) the ability to collaborate and make individual contributions on an unprecedented scale. To be effective in the 21st century, citizens and workers must be able to exhibit a range of functional and critical thinking skills related to information, media and technology.


	Learning Targets

	Standard 8.1 Computer and Information Literacy
The use of technology and digital tools requires knowledge and appropriate use of operations and related applications.



	Content Statements:  

Students will review knowledge of Home Key Finger Position

Students will review knowledge of Home Row, Top Row, & Bottom Row Fingering while continuing to develop accuracy & speed in typing.

Students will review knowledge of Using the Shift Key for Upper Case Letters and other symbols on Keys with double symbols.

Students will review knowledge of the number key pad and correct fingering for its use
 


	CPI #
	Cumulative Progress Indicator (CPI)

	1
	The student will demonstrate effective input of text and data, using touch keyboarding with proper technique.

	2
	Select and use appropriate tools and digital resources to accomplish a variety of tasks and to solve problems.



	
	

	
	

	
	


	Unit Essential Questions:
Why are proper keyboarding skills essential and how will these skills improve your productivity?

• How many future tasks will benefit from your computer application skills?

• How does collaboration enable groups to achieve common goals more efficiently?

• Why are digital tools and their effective use so vital for success in the 21st Century?


	Unit Enduring Understandings:

Success in the 21st-century is dependent on the ability to utilize digital tools and new technologies for collecting, organizing and managing data in order to stay competitive in an ever-changing global business environment.

• Students must begin to explore their talents and interests during their primary years and continue throughout their lives. In order to effectively explore and prepare for a career in a world that is consistently evolving, students must understand that lifelong

learning and skill building is imperative to sustain employment in the 21st-century.

• Correct keyboarding technique will increase efficiency not only as a student but in

future careers.

	Unit Learning Targets: 
Provide a three day refresher cycle of daily touch keyboarding technique and application in a whole group setting.
 

	Evidence of Learning

	Formative Assessments:

Student Progress Observation
Criteria and Goal Setting
Electronic files on student home drive



	Summative Assessment:  
District benchmark or interim assessments

End-of-unit or chapter tests

End-of-term or semester exams



	Lesson Timeframes

	Lesson Title:
	Timeframe (hours/days)

	Lesson One
Keyboarding Review
	3 Days @ 43 Minutes per day

	Lesson Two
Computer Basics Review
	7 Days @ 43 Minutes per day

	Lesson Three
Microsoft Word Module
	10 Days @ 43 Minutes per day

	Lesson Four
Microsoft Excel Module
	10 Days @ 43 Minutes per day

	Lesson Five
Microsoft PowerPoint Module
	10 Days @ 43 Minutes per day

	Lesson Six
Computer generated Design
	10 Days @ 43 Minutes per day

	Teacher Notes: 


	Lesson Plans

	Lesson Title: Keyboarding 

	Timeframe: 3 Days @ 43 Minutes per day

	Goals/Objectives:
Review knowledge of “Home Row” and “Anchor Keys”.
Review right hand typing usage.
Review left hand typing usage.


	Learning Activities/Instructional Strategies:

Practice drills for keys on the “Home Row”
Practice drills for keys used by right hand.
Practice drills for keys used by left hand.


	Equipment/Resources Needed:

PC with Keyboard
Typing Software


	Lesson Assessment:  Observe students as they work and check if they follow objectives of the lesson.  .  The teacher uses professional judgment on demonstrated skills of student work.  Assess progress of assignment to see if they remain on task.



	Teacher Notes:



	


	Unit Overview 

	Content Area:  Technology / Computers

	Unit Title: Computer Basics

	Target Course/Grade Levels: K-5

	Unit Summary:   
Computer is an electronic device which accepts data as input, performs processing on the data, and gives the desired output. A computer may be analog or digital computer.

Speed, accuracy, diligence, storage capability and versatility are the main characteristics of computer.

The computing devices have evolved from simple mechanical machines, like ABACUS, Napier’s bones, Slide Rule, Pascal’s Adding and Subtraction Machine, Leibniz’s Multiplication and Dividing Machine, Jacquard Punched Card System, Babbage’s Analytical Engine and Hollerith’s Tabulating Machine, to the first electronic computer.

Computer is an electronic device based on the input-process-output concept. Input/Output Unit, CPU and Memory unit are the three main components of computer.

Input/Output Unit consists of the Input unit which accepts data from the user and the Output unit that provides the processed data. CPU processes the input data, and, controls, coordinates and supervises the operations of the computer. CPU consists of ALU, CU and Registers. The memory unit stores programs, data and output, temporarily, during the processing. Additionally, storage unit or secondary memory is used for the storing of programs, data and output permanently.

Computers are used in various areas of our life. Education, entertainment, sports, advertising, medicine, science and engineering, government, office and home are some of the application areas of the computers.

Interdisciplinary Connections:  
Language Arts, Foreign Languages

21st Century Themes: 
ALL STUDENTS WILL USE DIGITAL TOOLS TO ACCESS, MANAGE, EVALUATE, AND SYNTHESIZE 

INFORMATION IN ORDER TO SOLVE PROBLEMS INDIVIDUALLY AND COLLABORATIVELY TO 

CREATE AND COMMUNICATE KNOWLEDGE



	Learning Targets

	Standards:  8.1 Computer and Information Literacy

Select and use appropriate tools and digital resources to accomplish a variety of tasks and to solve problems. 
Model appropriate online behaviors related to cyber safety, cyber bullying, cyber security, and cyber ethics.

Summarize the application of fair use and creative commons.

Demonstrate how information may be biased on a controversial issue.

	Content Statements:  

Students will review knowledge of Drive Options (e.g. Local, Networked)

Students will review knowledge of Saving Work to Different Drives

Students will review knowledge of using Printers

Students will review knowledge of Creating Folders To Organize Their Work

Students will learn when and how to reboot their computer

Students will learn how to check plug-ins and properly make connections

Students will suggest and use solutions to Printer Problems
Students will discuss behaviors as cyber bulling, hacking, and data theft/ownership. 

Students will discuss cyber safety, identity protection, cyber fraud, and posting personal information.  

 


	CPI #
	Cumulative Progress Indicator (CPI)

	1 
	The student will use basic technology vocabulary

	2
	The student will use common features of an operating system (e.g., creating and organizing files and folders).

	3
	The student will input and access data and text efficiently and accurately through proficient use of other input devices, such as the mouse.

	4
	The student will use network resources for storing and retrieving data.

	
	


	Unit Essential Questions:

- In a world of constant technological change, what skills should we learn?
- How do I choose which technological tools to use and when it is appropriate to use them?

- How can I transfer what I know to new technological situations/experiences?
- What are my responsibilities for using technology? What constitutes misuse and how can it best be prevented?

	Unit Enduring Understandings:

- Technology is constantly changing and requires continuous learning of new skills.
- Selection of technology should be based on personal and/or career needs assessment.
- A tool is only as good as the person using it.
- Technology use can have positive or negative impact on both users and those affected by their use.

• Technology is a process by which humans use nowledge to extend capabilities.

• The products of technology are not with out negative impacts.

• There is not always one ‘right’ answer when dealing with creative problem solving.

	Unit Learning Targets

Students will review knowledge of Rebooting the computer

Students will review knowledge of Plug-in Area

Through exploring icon on the desktop Students will become familiar with A, C & H Drives / Volumes

Using MS Word students will save a file to A, C &  H Drives / Volumes

Using MS Word students will print a document and select proper printer for data they are printing

Through “My Computer” or “Finder” icon on  the desktop students will create and delete folders within the H drive / Home volume
Through discussion and example, students will recognize online safety.

	Evidence of Learning

	Formative Assessments:

Teacher Observation & Evaluation
Student Projects
Electronic files on local and networked drives



	Summative Assessment:

End-of-unit or chapter tests

End-of-term or semester exams




	Lesson Plan

	Lesson Title:
	Timeframe (hours/days)

	Lesson One
Keyboarding 
	3 Days @ 43 Minutes per day

	Lesson Two
Computer Basics 
	7 Days @ 43 Minutes per day

	Lesson Three
Microsoft Word 
	10 Days @ 43 Minutes per day

	Lesson Four
Microsoft Excel Module
	10 Days @ 43 Minutes per day

	Lesson Five
Microsoft PowerPoint Module
	10 Days @ 43 Minutes per day

	Lesson Six
Computer generated Design
	10 Days @ 43 Minutes per day

	Teacher Notes: 



	Lesson Plans

	Lesson Title: Computer Basics 

	Timeframe: 7 Days @ 43 Minutes per day

	Goals/Objectives:

Review hardware used in class.

Review software used in class.                 

Review files category.

Review storage management.                  

Review peripheral equipment.
Review ethical behaviors.

Review cyber safety. 

	Learning Activities/Instructional Strategies:

Open PC and review parts Hard Drive, CD/DVD Drive, USB Ports, power supply, and RAM,                 

Install and uninstall software            

Review file naming give examples jpeg, mp3, bmp, gif, dll,.
Review file storage strategies, changing file locations, and file data layout.

Add and remove printers, scanners, and portable storage devices.

Discuss behaviors as cyber bulling, hacking, and data theft/ownership. 

Discuss cyber safety, identity protection, cyber fraud, and posting personal information.  

	Equipment/Resources Needed:

PC with Keyboard

Software

Printer

Flash drive 



	Lesson Assessment:  Observe students as they work and check if they follow objectives of the lesson.  .  The teacher uses professional judgment on demonstrated skills of student work.  Assess progress of assignment to see if they remain on task.

	Teacher Notes:



	


	Unit Overview 

	Content Area: Technology / Computers

	Unit Title:  Word Processing

	Target Course/Grade Levels:  K-5

	Unit Summary:  
The student will create documents with advanced text-formatting and graphics using word processing.

 
Interdisciplinary Connections:  
Language Arts, Foreign Languages
21st Century Themes: 

ALL STUDENTS WILL USE DIGITAL TOOLS TO ACCESS, MANAGE, EVALUATE, AND SYNTHESIZE 

INFORMATION IN ORDER TO SOLVE PROBLEMS INDIVIDUALLY AND COLLABORATIVELY TO 

CREATE AND COMMUNICATE KNOWLEDGE


	Learning Targets

	Standards: 8.2 Technology Education

All students will develop an understanding of the nature and impact of technology, engineering, technological design, and the designed world as they relate to the individual society, and the environment.


	Content Statements:  
Students will:
Modify page set up including margins and orientation

WordArt

Use various font sizes and styles

Apply bold, italics, and underline formatting to text

Insert a Textbox

Use proofing tools to check for spelling errors

Modify page set up including margins and orientation 

Create a hyperlink 

Apply a picture style to a specified picture 

Adjust line spacing 

Convert text to columns and utilize column breaks 

Modify bullets in a list 

Insert and modify a shape

Insert a clip art

Indent a bulleted list

Insert a Page Break

Convert existing text to a table

Insert rows into a table

Apply a table style

Apply a new theme to the document

 


	1
	Create professional documents (e.g., newsletter, personalized learning plan, business letter or flyer) using advanced features of a word processing program.

	2
	Select and use appropriate tools and digital resources to accomplish a variety of tasks and to solve problems

	
	

	
	

	
	

	
	


	Unit Essential Questions:

• Increased vocabulary content will be an asset not only for future educational courses, but also for personal accomplishment.

• Knowledge of computer applications is an important life skill needed in today’s technological world.

• Why are problem solving and critical thinking skills necessary to be successful in the 21st Century?

• Why is gathering and learning how to evaluate data from multiple sources so important in the 21st Century?


	Unit Enduring Understandings:

•Success in the 21st Century is dependent on the ability to utilize digital tools and new technologies for collecting, organizing and managing data in order to stay competitive in today’s technological world.

• Students must begin to explore their talents and interests during their primary years and continue throughout their lives. In order to effectively explore and prepare for a career in a world that is consistently evolving, students must understand that lifelong

learning and skill building is imperative to the 21st Century.

• Correct keyboarding technique will increase efficiency not only as a student but in future careers.

• Increased vocabulary content will be an asset not only for future educational courses, but also for personal accomplishment.

• Knowledge of computer applications is an important life skill needed in today’s

technological world.


	Unit Learning Targets

Student will learn to incorporate word processing and 21st-century skills in their daily lives.
 

	Evidence of Learning

	Formative Assessments:

Teacher Observation & Evaluation

Student Projects

Electronic files on local and networked drives

Microsoft Word project including basic formatting, grouping, duplicating, rotating, free floating pictures, backgrounds, borders, text boxes and toolbars.


	Summative Assessment:

End-of-unit or chapter tests

End-of-term or semester exams




	Lesson Timeframes

	Lesson Title:
	Timeframe (hours/days)

	Lesson 1

Keyboarding Review
	3 Days @ 43 Minutes per day

	Lesson 2

Computer Basics Review
	7 Days @ 43 Minutes per day

	Lesson 3

Microsoft Word Module
	10 Days @ 43 Minutes per day

	Lesson 4

Microsoft Excel Module
	10 Days @ 43 Minutes per day

	Lesson 5

Microsoft PowerPoint Module
	10 Days @ 43 Minutes per day

	Lesson 6

Computer generated Design
	10 Days @ 43 Minutes per day

	Teacher Notes: 



	Lesson Plans

	Lesson Title: Word Processing

	Timeframe: 10 Days @ 43 Minutes per day

	Goals/Objectives:

Use the project method to provide the knowledge of MS Word menus.
Review the “Home Menu”

Review the “Insert Menu”.

Review the “Page Layout Menu”.

Review the “Reference Menu”

Teach the method of how to print.


	Learning Activities/Instructional Strategies:

The project method is used to provide the knowledge of MS Word menus.

Students use a list of requirements to showcase the menu items and develop the project.


	Equipment/Resources Needed:

PC with Keyboard

Typing Software



	Lesson Assessment:  Observe students as they work and check if they follow objectives of the lesson.  .  The teacher uses professional judgment on demonstrated skills of student work.  Assess progress of assignment to see if they remain on task.



	Teacher Notes:



	


	Unit Overview 

	Content Area:  Technology / Computers

	Unit Title: Spreadsheets

	Target Course/Grade Levels:  K-5

	Unit Summary: 
The student will  Construct a spreadsheet, enter data, use mathematical or logical functions to manipulate and process data, generate charts and graphs, and interpret the results.

Interdisciplinary Connections:  
Language Arts, Math, Science
21st Century Themes: 
ALL STUDENTS WILL USE DIGITAL TOOLS TO ACCESS, MANAGE, EVALUATE, AND SYNTHESIZE 

INFORMATION IN ORDER TO SOLVE PROBLEMS INDIVIDUALLY AND COLLABORATIVELY TO 

CREATE AND COMMUNICATE KNOWLEDGE 



	Learning Targets

	Standards: 8.2 Technology Education

All students will develop an understanding of the nature and impact of technology, engineering, technological design, and the designed world as they relate to the individual society, and the environment.


	Content Statements:

Enter text and number data into a spreadsheet

Modify column width to a specific measurement

Modify row height to a specific measurement

Format text within selected cells 

Select a font style

Change font size

Apply bold, italics, or underline format

Select font color

Add a fill color to selected cells

Add a border to selected cells

Apply a number format to specific cells

Write various simple formulas

Modify page set up

Create simple and complex formulas to manage data

Use the fill handle to copy cell formulas from one cell to many cell
Use Excel’s basic functions from the Functions Library to perform standard calculations

Make changes to worksheet tabs within a spreadsheet including: 

Insert a worksheet

Delete a worksheet

Rename a worksheet

Copy data from one worksheet to another

Group cells using the Subtotal Command

Sort data in a worksheet using a multiple level sort

Format data as a table

Modify text alignment for a specified row or column

Freeze a row to keep it visible for you while you are working with data

Modify page set up

Modify column and row formatting including wrap text

Delete specific data

Create a chart and modify the:  

Chart layout

Chart name

Chart style

Apply conditional formatting

Insert a pivot table to include specific data

Rename a worksheet




	CPI #
	Cumulative Progress Indicator (CPI)

	1

	Plan and create a simple database, define fields, input data and produce a report using sort and query. 



	2
	Generate a spreadsheet to calculate, graph and present information. 



	
	

	
	

	
	


	Unit Essential Questions:

• Why are digital tools and their effective use so vital for success in the 21st Century?

• Why are problem solving and critical thinking skills necessary to be successful in the 21st Century?

• Why is gathering and learning how to evaluate data from multiple sources so important in the 21st Century?
• In a world of constant technological change, what skills should we learn?

• How do I choose which technological tools to use and when it is appropriate to use them?

	Unit Enduring Understandings:

• Success in the 21st Century is dependent on the ability to utilize digital tools and new technologies for collecting, organizing and managing data in order to stay competitive

in today’s technological world.

• Students must begin to explore their talents and interests during their primary years and continue throughout their lives. In order to effectively explore and prepare for a

career in a world that is consistently evolving, students must understand that lifelong learning and skill building is imperative to the 21st Century.

• Correct keyboarding technique will increase efficiency not only as a student but in future careers.

• Increased vocabulary content will be an asset not only for future educational courses, but also for personal accomplishment.

• Knowledge of computer applications is an important life skill needed in today’s technological world.


	Unit Learning Targets:
Student will use spreadsheets to gain knowledge and skill with various advanced features and functions including: data entry, creating and using graphs and charts to support learning and research; and interpret, create, and graph using a spreadsheet program.
 

	Evidence of Learning

	Formative Assessments:

Teacher Observation & Evaluation

Student Projects

Electronic files on local and networked drives

Excel project including basic formatting of cells, wrapping, use of formulas, copying formulas, adding and deleting rows, sorting, auto-sizing columns and rows, and creation of charts.


	Summative Assessment:

End-of-unit or chapter tests

End-of-term or semester exams




	Lesson Timeframes

	Lesson Title:
	Timeframe (hours/days)

	Lesson 1

Keyboarding Review
	3 Days @ 43 Minutes per day

	Lesson 2

Computer Basics Review
	7 Days @ 43 Minutes per day

	Lesson 3

Microsoft Word Module
	10 Days @ 43 Minutes per day

	Lesson 4

Microsoft Excel Module
	10 Days @ 43 Minutes per day

	Lesson 5

Microsoft PowerPoint Module
	10 Days @ 43 Minutes per day

	Lesson 6

Computer generated Design
	10 Days @ 43 Minutes per day

	Teacher Notes: 



	Lesson Plans

	Lesson Title: Spreadsheets

	Timeframe: 10 Days @ 43 Minutes per day

	Goals/Objectives:

Use the project method to provide the knowledge of MS Excel menus.

Review the “Home Menu”

Review the “Insert Menu”.

Review the “Page Layout Menu”.

Review the “Review Menu”

Teach the method of how to print.



	Learning Activities/Instructional Strategies:

The project method is used to provide the knowledge of MS Excel menus.

Students use a list of requirements to showcase the menu items and develop the project.



	Equipment/Resources Needed:

PC with Keyboard

Typing Software



	Lesson Assessment:  Observe students as they work and check if they follow objectives of the lesson.  .  The teacher uses professional judgment on demonstrated skills of student work.  Assess progress of assignment to see if they remain on task.



	Teacher Notes:



	


	Unit Overview 

	Content Area: Technology / Computers

	Unit Title:  Presentation Software

	Target Course/Grade Levels: K-5

	Unit Summary:

Interdisciplinary Connections: Language Arts, Foreign Languages, Science, Math
21st Century Themes: 
Use technology as a tool to research, organize, evaluate and communicate information

Use digital technologies (computers, PDAs, media players, GPS,  etc.), communication/networking tools and social networks appropriately to access, manage, integrate, evaluate and create information to successfully function in a knowledge economy.


	Learning Targets

	Standards: 8.2 Technology Education

All students will develop an understanding of the nature and impact of technology, engineering, technological design, and the designed world as they relate to the individual society, and the environment.



	Content Statements:
Use common PowerPoint slide layouts to create new slides 

Insert new slides at various places in the presentation 

Utilize different layouts 

Add text to slides using place holder 

Change the text font and font size on slides 

Add clip art and other pictures to slide 

Use and modify bulleted and numbered lists in slides 

Apply a theme to all slides in presentation 

Proof the presentation using the spelling tool 

Insert and add text to a text box 

Apply a transition effect to slides

Apply animation and multiple animation effects to text and other objects

Modify a theme

Modify lists

Apply picture styles to clip art or pictures

Group pictures on a slide

Format pictures

Proof the presentation using the spelling tool

Insert and modify a shape on a slide

Add a sound effect to a slide

Delete a sound effect from a slide

Hide a sound during the slide show

Optional use of Word Art 

Insert a hyperlink on a slide

Add a SmartArt graphic to a slide            
Hide a slide

Add a transition effect to slides

Insert and add text to a table

Apply a table style to a table

Insert and enter text into a chart

Apply a chart style to a chart



	


	CPI #
	Cumulative Progress Indicator (CPI)

	1
2
	Create a multi media presentation including sound and images.

Select and use appropriate tools and digital resources to accomplish a

variety of tasks and to solve problems.


	
	

	
	

	
	

	
	


	Unit Essential Questions:

• How does collaboration enable groups to achieve common goals more efficiently?

• Why are collaboration and the opportunity to compete necessary in order to develop leadership skills?

• How do we learn to effectively communicate with people from different cultural backgrounds in order to understand their cultural perspective?

• How will career plans be affected and altered in response to changes in society and the economy?

• Why are digital tools and their effective use so vital for success in the 21st Century?

• How do we as citizens in the 21st Century navigate through the ethical and unethical uses of communication and media?

• How do film and media express and enhance life experiences?

• What are the ethnics and responsibilities associated with the use of information?

• How is media literacy integral to digital citizenship?

• How does the appropriate choice of media allow for more effective communication?

• How is communication influenced by society and culture?

• How do we choose the most effective medium for a message?

• What are the purpose, function and requirements of a script in a filmed project?

	Unit Enduring Understandings:

• The appropriate choice and creative use of media allows      us to communicate effectively.

• Technology and information tools can enhance work, education, and communication.

• Media provides opportunities for collaboration and has the power to persuade and influence society.

• Media in a democratic society provides a forum for public discussion, open exchange of ideas and evaluation of multiple perspectives.

• The integrity of the worldwide technology community depends upon its members exhibiting safe and ethical use of electronic resources.

• Information systems, both printed and digital, are the centers of intellectual, academic, social, and cultural life.


	Unit Learning Targets:
The student will produce a multimedia project using text, graphics, moving images, and sound.

  

	Evidence of Learning

	Formative Assessments:

Teacher Observation & Evaluation

Student Projects

Electronic files on local and networked drives

PowerPoint project including basic slide creation, layouts, backgrounds, animations, transitions, sounds, hyperlinks, and group collaboration.



	Summative Assessment:

End-of-unit or chapter tests

End-of-term or semester exams




	Lesson Timeframes

	Lesson Title:
	Timeframe (hours/days)

	Lesson 1

Keyboarding Review
	3 Days @ 43 Minutes per day

	Lesson 2

Computer Basics Review
	7 Days @ 43 Minutes per day

	Lesson 3

Microsoft Word Module
	10 Days @ 43 Minutes per day

	Lesson 4

Microsoft Excel Module
	10 Days @ 43 Minutes per day

	Lesson 5

Microsoft PowerPoint Module
	10 Days @ 43 Minutes per day

	Lesson 6

Computer generated Design
	10 Days @ 43 Minutes per day

	Teacher Notes: 



	Lesson Plans

	Lesson Title: Presentation Software

	Timeframe: 10 Days @ 43 Minutes per day

	Goals/Objectives:

Use the project method to provide the knowledge of MS PowerPoint menus.

Review the “Home Menu”

Review the “Insert Menu”.

Review the “Design Menu”.

Review the “Transition Menu”.

Review the “Animation Menu”.

Review the “Slide Show Menu”.

Review the “Review Menu”. 

Teach the method of how to print.



	Learning Activities/Instructional Strategies:

The project method is used to provide the knowledge of MS PowerPoint menus.

Students use a list of requirements to showcase the menu items and develop the project.



	Equipment/Resources Needed:

PC with Keyboard

Typing Software



	Lesson Assessment:  Observe students as they work and check if they follow objectives of the lesson.  .  The teacher uses professional judgment on demonstrated skills of student work.  Assess progress of assignment to see if they remain on task.



	Teacher Notes:



	


	Unit Overview 

	Content Area:  Technology / Computers

	Unit Title:  Computer Generated Design

	Target Course/Grade Levels:  6-8

	Unit Summary:  
Through the use of a design oriented program, students will apply various design fundamentals ranging from drafting, graphics or web page design
Interdisciplinary Connections:  
Art, Industrial Arts, Language Arts
21st Century Themes:  
Use technology as a tool to research, organize, evaluate and communicate information

Use digital technologies (computers, PDAs, media players, GPS,  etc.), communication/networking tools and social networks appropriately to access, manage, integrate, evaluate and create information to successfully function in a knowledge economy.



	Learning Targets

	Standards:  
8.1 Computer and Information Literacy

Select and use appropriate tools and digital resources to accomplish a variety of tasks and to solve problems. 



	Content Statements:

Create and design a computer generated project

 


	CPI #
	Cumulative Progress Indicator (CPI)

	1
	The student uses computer applications to modify information independently and/or collaboratively to solve problems.

 

	
	

	
	

	
	

	
	


	Unit Essential Questions:
How can I transfer what I know to new technological situations/experiences?
What are my responsibilities for using technology? What constitutes misuse and how can it best be prevented?

	Unit Enduring Understandings:

- Technological outcomes have the potential for anticipated and unanticipated positive and negative results.
- The design process is fundamental to technology and engineering.

- A system has interrelated components designed to collectively achieve a desired goal.
- All technological activities use resources that include tools/machines, materials, information, energy, capital, time and people.


	Unit Learning Targets

Student will…

• Identify, analyze, and apply knowledge to different areas of technology

• Apply the steps of the Design Process to a technological problem

• Evaluate and satisfy a Design Challenge

• Develop a critical and creative approach to solving a Design Challenge

• Work safely and with appropriate tools

• Express ideas clearly in written, oral, and physical demonstrations

• Use appropriate vocabulary in relation to technological problems

 

	Evidence of Learning

	Formative Assessments:

Teacher Observation & Evaluation

Student Projects

Electronic files on local and networked drives



	Summative Assessment:

End-of-unit or chapter tests

End-of-term or semester exams


	Lesson Timeframes

	Lesson Title:
	Timeframe (hours/days)

	Lesson 1

Keyboarding Review
	3 Days @ 43 Minutes per day

	Lesson 2

Computer Basics Review
	7 Days @ 43 Minutes per day

	Lesson 3

Microsoft Word Module
	10 Days @ 43 Minutes per day

	Lesson 4

Microsoft Excel Module
	10 Days @ 43 Minutes per day

	Lesson 5

Microsoft PowerPoint Module
	10 Days @ 43 Minutes per day

	Lesson 6

Computer generated Design
	10 Days @ 43 Minutes per day

	Teacher Notes: 



	Lesson Plans

	Lesson Title: Computer generated Design

	Timeframe: 10 Days @ 43 Minutes per day

	Goals/Objectives:

Use the project method to provide a variety of uses for the MS PowerPoint menus.

Review the “Home Menu”

Review the “Insert Menu”.

Review the “Page Layout Menu”.



	Learning Activities/Instructional Strategies:

Menus are used to demonstrate the wide variety tasks that may be accomplished using the software.

Students use a list of requirements to showcase the menu items and develop the design project.



	Equipment/Resources Needed:

PC with Keyboard

Design Software



	Lesson Assessment:  Observe students as they work and check if they follow objectives of the lesson.  .  The teacher uses professional judgment on demonstrated skills of student work.  Assess progress of assignment to see if they remain on task.



	Teacher Notes:
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